# CVE-2024-37280: Elasticsearch StackOverflow vulnerability

> Attackers can cause a Denial of Service in Elasticsearch by ingesting documents into indices with experimental passthrough dynamic field mappings.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2024
- **Updated:** 16 Aug 2024
- **Also known as:** BIT-elasticsearch-2024-37280, GHSA-4q22-422g-m4pj, UBUNTU-CVE-2024-37280

## What is CVE-2024-37280?

CVE-2024-37280 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 13 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was discovered in Elasticsearch, affecting document ingestion when an index template contains a dynamic field mapping of “passthrough” type. Under certain circumstances, ingesting documents in this index would cause a StackOverflow exception to be thrown and ultimately lead to a Denial of Service. Note that passthrough fields is an experimental feature.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-37280?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 8.13.1 | 8.14.0 |
| `org.elasticsearch:elasticsearch` | Maven | From 8.13.1 | 8.14.0 |
| `elasticsearch` | Bitnami | From 8.13.1 | 8.14.0 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2024-37280?

Upgrade org.elasticsearch:elasticsearch to 8.14.0 or later.

## Is CVE-2024-37280 being exploited?

There is no known exploitation of CVE-2024-37280 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37280 and fix it if it is affected.

What it is: CVE-2024-37280 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 13 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37280 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 8.13.1; fixed in 8.14.0
- org.elasticsearch:elasticsearch (Maven): affected from 8.13.1; fixed in 8.14.0
- elasticsearch (Bitnami): affected from 8.13.1; fixed in 8.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37280/ (Markdown: https://insights.sbomify.com/CVE-2024-37280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37280
- OSV: https://osv.dev/vulnerability/CVE-2024-37280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37280/
Summaries are generated and may contain mistakes; the official description above is the record.
