# CVE-2024-37285: Kibana arbitrary code execution via YAML deserialization

> A malicious user with specific Elasticsearch and Kibana privileges can achieve arbitrary code execution by submitting a crafted YAML document.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2024
- **Updated:** 14 Nov 2024
- **Also known as:** BIT-elk-2024-37285, BIT-kibana-2024-37285, GHSA-p9rc-m4r5-4rpr

## What is CVE-2024-37285?

CVE-2024-37285 is a critical unsafe deserialization vulnerability in Elastic Kibana, published on 14 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A deserialization issue in Kibana can lead to arbitrary code execution when Kibana attempts to parse a YAML document containing a crafted payload. A successful attack requires a malicious user to have a combination of both specific  Elasticsearch indices privileges https://www.elastic.co/guide/en/elasticsearch/reference/current/defining-roles.html#roles-indices-priv  and  Kibana privileges https://www.elastic.co/guide/en/fleet/current/fleet-roles-and-privileges.html  assigned to them.

The following Elasticsearch indices permissions are required

  *  write privilege on the system indices .kibana_ingest*
  *  The allow_restricted_indices flag is set to true

Any of the following Kibana privileges are additionally required

  *  Under Fleet the All privilege is granted
  *  Under Integration the Read or All privilege is granted
  *  Access to the fleet-setup privilege is gained through the Fleet Server’s service account token

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-37285?

2 open source packages ship an affected version, including kibana and elk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kibana` | Bitnami | From 8.10.0 | 8.15.1 |
| `elk` | Bitnami | From 8.10.0 | 8.15.1 |

Products: Elastic Kibana.

## How do I fix CVE-2024-37285?

Upgrade kibana to 8.15.1 or later.

## Is CVE-2024-37285 being exploited?

There is no known exploitation of CVE-2024-37285 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Kibana

- [CVE-2019-7609](https://insights.sbomify.com/CVE-2019-7609/): Kibana Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2025-25015](https://insights.sbomify.com/CVE-2025-25015/): Kibana arbitrary code execution via prototype pollution (critical 9.9)
- [CVE-2024-37288](https://insights.sbomify.com/CVE-2024-37288/): Deserialization in Kibana (critical 9.9)
- [CVE-2023-31415](https://insights.sbomify.com/CVE-2023-31415/): Code injection in Kibana (critical 9.9)
- [CVE-2018-17245](https://insights.sbomify.com/CVE-2018-17245/): Information disclosure in Kibana (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37285 and fix it if it is affected.

What it is: CVE-2024-37285 is a critical unsafe deserialization vulnerability in Elastic Kibana, published on 14 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37285 in the wild and no public exploit code.

Affected packages and fixed versions:
- kibana (Bitnami): affected from 8.10.0; fixed in 8.15.1
- elk (Bitnami): affected from 8.10.0; fixed in 8.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37285/ (Markdown: https://insights.sbomify.com/CVE-2024-37285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37285
- OSV: https://osv.dev/vulnerability/CVE-2024-37285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37285/
Summaries are generated and may contain mistakes; the official description above is the record.
