# CVE-2024-37295: Aimeos Core remote code execution in web server context

> Administrative users can upload malicious files disguised as images to execute arbitrary code on the web server.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** CVE-2024-36811, GHSA-rhc2-23c2-ww7c

## What is CVE-2024-37295?

CVE-2024-37295 is a high-severity vulnerability in aimeos-core, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Aimeos is an Open Source e-commerce framework for online shops. Starting in version 2024.01.1 and prior to version 2024.04.5, a user with administrative privileges can upload files that look like images but contain PHP code which can then be executed in the context of the web server. Version 2024.04.5 fixes the issue.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2024-37295?

2 open source packages ship an affected version, including aimeos/aimeos-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/aimeos-core` | Packagist | From 2024.04.1 | 2024.04.5 |
| `aimeos/aimeos-core` | Packagist | From 2024.04.1 | 2024.04.5 |

## How do I fix CVE-2024-37295?

Upgrade aimeos/aimeos-core to 2024.04.5 or later.

## Is CVE-2024-37295 being exploited?

There is no known exploitation of CVE-2024-37295 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37295 and fix it if it is affected.

What it is: CVE-2024-37295 is a high-severity vulnerability in aimeos-core, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37295 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/aimeos-core (Packagist): affected from 2024.04.1; fixed in 2024.04.5
- aimeos/aimeos-core (Packagist): affected from 2024.04.1; fixed in 2024.04.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37295/ (Markdown: https://insights.sbomify.com/CVE-2024-37295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37295
- OSV: https://osv.dev/vulnerability/CVE-2024-37295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37295/
Summaries are generated and may contain mistakes; the official description above is the record.
