# CVE-2024-37296: Aimeos HTML client vulnerable to digital products download without proper payment status check

> Attackers can download digital products without valid payment due to missing payment status checks in the Aimeos HTML client.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-v4g2-cm5v-cxv7

## What is CVE-2024-37296?

CVE-2024-37296 is a medium-severity vulnerability in aimeos ai-client-html, published on 11 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Aimeos HTML client provides Aimeos HTML components for e-commerce projects. Starting in version 2020.04.1 and prior to versions 2020.10.27, 2021.10.21, 2022.10.12, 2023.10.14, and 2024.04.5, digital downloads sold in online shops can be downloaded without valid payment, e.g. if the payment didn't succeed. Versions 2020.10.27, 2021.10.21, 2022.10.12, 2023.10.14, and 2024.04.5 fix this issue.

Weakness: CWE-862 (Missing Authorization), CWE-841 (Improper Enforcement of Behavioral Workflow)

## Which versions are affected by CVE-2024-37296?

10 open source packages ship an affected version, including aimeos/ai-client-html.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/ai-client-html` | Packagist | From 2020.04.1 | 2020.10.27 |
| `aimeos/ai-client-html` | Packagist | From 2020.04.1 | 2020.10.27 |
| `aimeos/ai-client-html` | Packagist | From 2021.04.1 | 2021.10.21 |
| `aimeos/ai-client-html` | Packagist | From 2021.04.1 | 2021.10.21 |
| `aimeos/ai-client-html` | Packagist | From 2022.04.1 | 2022.10.12 |
| `aimeos/ai-client-html` | Packagist | From 2022.04.1 | 2022.10.12 |
| `aimeos/ai-client-html` | Packagist | From 2023.04.1 | 2023.10.14 |
| `aimeos/ai-client-html` | Packagist | From 2023.04.1 | 2023.10.14 |
| `aimeos/ai-client-html` | Packagist | From 2024.04.1 | 2024.04.5 |
| `aimeos/ai-client-html` | Packagist | From 2024.04.1 | 2024.04.5 |

## How do I fix CVE-2024-37296?

Upgrade aimeos/ai-client-html to a fixed version for your release line: 2020.10.27, 2021.10.21, 2022.10.12 or 2023.10.14.

## Is CVE-2024-37296 being exploited?

There is no known exploitation of CVE-2024-37296 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37296 and fix it if it is affected.

What it is: CVE-2024-37296 is a medium-severity vulnerability in aimeos ai-client-html, published on 11 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37296 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/ai-client-html (Packagist): affected from 2020.04.1; fixed in 2020.10.27
- aimeos/ai-client-html (Packagist): affected from 2020.04.1; fixed in 2020.10.27
- aimeos/ai-client-html (Packagist): affected from 2021.04.1; fixed in 2021.10.21
- aimeos/ai-client-html (Packagist): affected from 2021.04.1; fixed in 2021.10.21
- aimeos/ai-client-html (Packagist): affected from 2022.04.1; fixed in 2022.10.12
- aimeos/ai-client-html (Packagist): affected from 2022.04.1; fixed in 2022.10.12
- aimeos/ai-client-html (Packagist): affected from 2023.04.1; fixed in 2023.10.14
- aimeos/ai-client-html (Packagist): affected from 2023.04.1; fixed in 2023.10.14
- aimeos/ai-client-html (Packagist): affected from 2024.04.1; fixed in 2024.04.5
- aimeos/ai-client-html (Packagist): affected from 2024.04.1; fixed in 2024.04.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37296/ (Markdown: https://insights.sbomify.com/CVE-2024-37296/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37296
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37296
- OSV: https://osv.dev/vulnerability/CVE-2024-37296

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37296/
Summaries are generated and may contain mistakes; the official description above is the record.
