# CVE-2024-37297: WooCommerce has a Cross-Site Scripting Vulnerability in checkout & registration forms

> Attackers can inject malicious scripts into checkout and registration forms via manipulated links, potentially hijacking user sessions and data.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cv23-q6gh-xfrf

## What is CVE-2024-37297?

CVE-2024-37297 is a medium-severity cross-site scripting vulnerability in woocommerce, published on 12 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

WooCommerce is an open-source e-commerce platform built on WordPress. A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session. The URL content is read through the `Sourcebuster.js` library and then inserted without proper sanitization to the classic checkout and registration forms. Versions 8.8.5 and 8.9.3 contain a patch for the issue. As a workaround, one may disable the Order Attribution feature.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-37297?

4 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `woocommerce/woocommerce` | Packagist | From 8.8.0 | 8.8.5 |
| `woocommerce/woocommerce` | Packagist | From 8.8.0 | 8.8.5 |
| `woocommerce/woocommerce` | Packagist | From 8.9.0 | 8.9.3 |
| `woocommerce/woocommerce` | Packagist | From 8.9.0 | 8.9.3 |

Products: Woocommerce Woocommerce.

## How do I fix CVE-2024-37297?

Upgrade woocommerce/woocommerce to a fixed version for your release line: 8.8.5 or 8.9.3.

## Is CVE-2024-37297 being exploited?

There is no known exploitation of CVE-2024-37297 in the wild and no public exploit code.

## Other vulnerabilities in woocommerce

- [CVE-2019-20891](https://insights.sbomify.com/CVE-2019-20891/): WooCommerce Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2017-18356](https://insights.sbomify.com/CVE-2017-18356/): Code injection in n/a (high 8.8)
- [CVE-2018-20714](https://insights.sbomify.com/CVE-2018-20714/): Path traversal in n/a (high 8.1)
- [CVE-2025-5062](https://insights.sbomify.com/CVE-2025-5062/): WooCommerce <= 9.4.2 - PostMessage-Based Cross-Site Scripting (medium 6.1)
- [CVE-2019-9168](https://insights.sbomify.com/CVE-2019-9168/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37297 and fix it if it is affected.

What it is: CVE-2024-37297 is a medium-severity cross-site scripting vulnerability in woocommerce, published on 12 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-37297 in the wild and no public exploit code.

Affected packages and fixed versions:
- woocommerce/woocommerce (Packagist): affected from 8.8.0; fixed in 8.8.5
- woocommerce/woocommerce (Packagist): affected from 8.8.0; fixed in 8.8.5
- woocommerce/woocommerce (Packagist): affected from 8.9.0; fixed in 8.9.3
- woocommerce/woocommerce (Packagist): affected from 8.9.0; fixed in 8.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37297/ (Markdown: https://insights.sbomify.com/CVE-2024-37297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37297
- OSV: https://osv.dev/vulnerability/CVE-2024-37297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37297/
Summaries are generated and may contain mistakes; the official description above is the record.
