CVE-2024-37299 Discourse vulnerable to DoS via Tag Group

Medium 4.9 Published Updated

Attackers can cause denial of service by submitting excessively long tag group names, affecting Discourse forum availability.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-37299?

CVE-2024-37299 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 30 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, crafting requests to submit very long tag group names can reduce the availability of a Discourse instance. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.

Weakness: CWE-400

Which versions are affected by CVE-2024-37299?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.2.5

Products include Discourse Discourse.

How do I fix CVE-2024-37299?

Upgrade discourse to 3.2.5 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-37299 being exploited?

There is no known exploitation of CVE-2024-37299 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2024-37299, GHSA-4j6h-9pjp-5476.

Is CVE-2024-37299 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free