CVE-2024-37300 Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-37300?

CVE-2024-37300 is a high-severity vulnerability in jupyterhub oauthenticator, published on 12 Jun 2024.

Official description

OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. JupyterHub < 5.0, when used with `GlobusOAuthenticator`, could be configured to allow all users from a particular institution only. This worked fine prior to JupyterHub 5.0, because `allow_all` did not take precedence over `identity_provider`. Since JupyterHub 5.0, `allow_all` does take precedence over `identity_provider`. On a hub with the same config, now all users will be allowed to login, regardless of `identity_provider`. `identity_provider` will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. As a workaround, do not upgrade to JupyterHub 5.0 when using `GlobusOAuthenticator` in the prior configuration.

Weakness: CWE-863

Which versions are affected by CVE-2024-37300?

3 open source packages ship an affected version, including oauthenticator.

PackageAffectedFixed in
oauthenticator PyPIAll versions16.3.1
oauthenticator PyPIAll versions16.3.1
oauthenticator PyPIAll versions16.3.1

How do I fix CVE-2024-37300?

Upgrade oauthenticator to 16.3.1 or later.

Is CVE-2024-37300 being exploited?

There is no known exploitation of CVE-2024-37300 in the wild and no public exploit code.

Sources

Also known as GHSA-gprj-3p75-f996, PYSEC-2026-1711.

Is CVE-2024-37300 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free