{"answers":{"affected":"3 open source packages ship an affected version, including oauthenticator.","exploited":"There is no known exploitation of CVE-2024-37300 in the wild and no public exploit code.","fix":"Upgrade oauthenticator to 16.3.1 or later.","what":"CVE-2024-37300 is a high-severity vulnerability in jupyterhub oauthenticator, published on 12 Jun 2024."},"fix_prompt":"Check this codebase for CVE-2024-37300 and fix it if it is affected.\n\nWhat it is: CVE-2024-37300 is a high-severity vulnerability in jupyterhub oauthenticator, published on 12 Jun 2024. \nExploitation: There is no known exploitation of CVE-2024-37300 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- oauthenticator (PyPI): affected all versions; fixed in 16.3.1\n- oauthenticator (PyPI): affected all versions; fixed in 16.3.1\n- oauthenticator (PyPI): affected all versions; fixed in 16.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37300/ (Markdown: https://insights.sbomify.com/CVE-2024-37300/index.md)","id":"CVE-2024-37300","markdown":"https://insights.sbomify.com/CVE-2024-37300/index.md","name":"CVE-2024-37300","record":{"aliases":["GHSA-gprj-3p75-f996","PYSEC-2026-1711"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. JupyterHub \u003c 5.0, when used with `GlobusOAuthenticator`, could be configured to allow all users from a particular institution only. This worked fine prior to JupyterHub 5.0, because `allow_all` did not take precedence over `identity_provider`. Since JupyterHub 5.0, `allow_all` does take precedence over `identity_provider`. On a hub with the same config, now all users will be allowed to login, regardless of `identity_provider`. `identity_provider` will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. As a workaround, do not upgrade to JupyterHub 5.0 when using `GlobusOAuthenticator` in the prior configuration.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0","id":"CVE-2024-37300","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"document-merge-service vulnerable to Remote Code Execution via Server-Side Template Injection","id":"CVE-2024-37301"},"packages":[{"ecosystem":"PyPI","fixed":["16.3.1"],"introduced":["0"],"last_affected":[],"package":"oauthenticator","purl":null,"source":"GHSA-gprj-3p75-f996"},{"ecosystem":"PyPI","fixed":["16.3.1"],"introduced":["0"],"last_affected":[],"package":"oauthenticator","purl":"pkg:pypi/oauthenticator","source":"GHSA-gprj-3p75-f996"},{"ecosystem":"PyPI","fixed":["16.3.1"],"introduced":["0"],"last_affected":[],"package":"oauthenticator","purl":"pkg:pypi/oauthenticator","source":"PYSEC-2026-1711"}],"prev":{"headline":"Discourse vulnerable to DoS via Tag Group","id":"CVE-2024-37299"},"products":["oauthenticator"],"published":"2024-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["jupyterhub"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-37300/"}