CVE-2024-37301 document-merge-service vulnerable to Remote Code Execution via Server-Side Template Injection

High 7.2 Published Updated

Attackers can achieve remote code execution and full system takeover via server-side template injection in the document merge service.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-37301?

CVE-2024-37301 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Versions 6.5.1 and prior are vulnerable to remote code execution via server-side template injection which, when executed as root, can result in full takeover of the affected system. As of time of publication, no patched version exists, nor have any known workarounds been disclosed.

Weakness: CWE-1336

Which versions are affected by CVE-2024-37301?

3 open source packages ship an affected version, including document-merge-service.

PackageAffectedFixed in
document-merge-service PyPIAll versions6.5.2
document-merge-service PyPIAll versions6.5.2
document-merge-service PyPIAll versions6.5.2

How do I fix CVE-2024-37301?

Upgrade document-merge-service to 6.5.2 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-37301 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37301 exists.

Sources

Also known as GHSA-v5gf-r78h-55q6, PYSEC-2026-1314.

Is CVE-2024-37301 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free