{"answers":{"affected":"3 open source packages ship an affected version, including document-merge-service.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37301 exists.","fix":"Upgrade document-merge-service to 6.5.2 or later.","what":"CVE-2024-37301 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-37301 and fix it if it is affected.\n\nWhat it is: CVE-2024-37301 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37301 exists.\n\nAffected packages and fixed versions:\n- document-merge-service (PyPI): affected all versions; fixed in 6.5.2\n- document-merge-service (PyPI): affected all versions; fixed in 6.5.2\n- document-merge-service (PyPI): affected all versions; fixed in 6.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37301/ (Markdown: https://insights.sbomify.com/CVE-2024-37301/index.md)","id":"CVE-2024-37301","markdown":"https://insights.sbomify.com/CVE-2024-37301/index.md","name":"CVE-2024-37301","record":{"aliases":["GHSA-v5gf-r78h-55q6","PYSEC-2026-1314"],"analysis":{"component_type":"server_software","fix_type":"no_fix_stated","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Document merge service","requires_auth":"high_privilege","summary":"Attackers can achieve remote code execution and full system takeover via server-side template injection in the document merge service.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Versions 6.5.1 and prior are vulnerable to remote code execution via server-side template injection which, when executed as root, can result in full takeover of the affected system. As of time of publication, no patched version exists, nor have any known workarounds been disclosed.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"document-merge-service vulnerable to Remote Code Execution via Server-Side Template Injection","id":"CVE-2024-37301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Synapse denial of service through media disk space consumption","id":"CVE-2024-37302"},"packages":[{"ecosystem":"PyPI","fixed":["6.5.2"],"introduced":["0"],"last_affected":[],"package":"document-merge-service","purl":null,"source":"GHSA-v5gf-r78h-55q6"},{"ecosystem":"PyPI","fixed":["6.5.2"],"introduced":["0"],"last_affected":[],"package":"document-merge-service","purl":"pkg:pypi/document-merge-service","source":"GHSA-v5gf-r78h-55q6"},{"ecosystem":"PyPI","fixed":["6.5.2"],"introduced":["0"],"last_affected":[],"package":"document-merge-service","purl":"pkg:pypi/document-merge-service","source":"PYSEC-2026-1314"}],"prev":{"headline":"Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0","id":"CVE-2024-37300"},"products":["document-merge-service"],"published":"2024-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-04","vendors":["adfinis"]},"summary":"Attackers can achieve remote code execution and full system takeover via server-side template injection in the document merge service.","url":"https://insights.sbomify.com/CVE-2024-37301/"}