# CVE-2024-37301: document-merge-service vulnerable to Remote Code Execution via Server-Side Template Injection

> Attackers can achieve remote code execution and full system takeover via server-side template injection in the document merge service.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2024
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-v5gf-r78h-55q6, PYSEC-2026-1314

## What is CVE-2024-37301?

CVE-2024-37301 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Versions 6.5.1 and prior are vulnerable to remote code execution via server-side template injection which, when executed as root, can result in full takeover of the affected system. As of time of publication, no patched version exists, nor have any known workarounds been disclosed.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2024-37301?

3 open source packages ship an affected version, including document-merge-service.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `document-merge-service` | PyPI | All versions | 6.5.2 |
| `document-merge-service` | PyPI | All versions | 6.5.2 |
| `document-merge-service` | PyPI | All versions | 6.5.2 |

## How do I fix CVE-2024-37301?

Upgrade document-merge-service to 6.5.2 or later.

## Is CVE-2024-37301 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37301 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37301 and fix it if it is affected.

What it is: CVE-2024-37301 is a high-severity code injection vulnerability in adfinis document-merge-service, published on 11 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37301 exists.

Affected packages and fixed versions:
- document-merge-service (PyPI): affected all versions; fixed in 6.5.2
- document-merge-service (PyPI): affected all versions; fixed in 6.5.2
- document-merge-service (PyPI): affected all versions; fixed in 6.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37301/ (Markdown: https://insights.sbomify.com/CVE-2024-37301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37301
- OSV: https://osv.dev/vulnerability/CVE-2024-37301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37301/
Summaries are generated and may contain mistakes; the official description above is the record.
