# CVE-2024-37302: Synapse denial of service through media disk space consumption

> Unauthenticated attackers can exhaust disk space by triggering excessive remote media downloads, causing denial of service in Synapse Matrix homeservers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-4mhg-xv73-xq2x, PYSEC-2024-286, UBUNTU-CVE-2024-37302

## What is CVE-2024-37302?

CVE-2024-37302 is a high-severity denial of service vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver. Synapse versions before 1.106 are vulnerable to a disk fill attack, where an unauthenticated adversary can induce Synapse to download and cache large amounts of remote media. The default rate limit strategy is insufficient to mitigate this. This can lead to a denial of service, ranging from further media uploads/downloads failing to completely unavailability of the Synapse process, depending on how Synapse was deployed. Synapse 1.106 introduces a new "leaky bucket" rate limit on remote media downloads to reduce the amount of data a user can request at a time. This does not fully address the issue, but does limit an unauthenticated user's ability to request large amounts of data to be cached.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-37302?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.106 |
| `matrix-synapse` | PyPI | All versions | 1.106 |
| `matrix-synapse` | PyPI | All versions | 1.106.0 |

Products: Matrix Synapse.

## How do I fix CVE-2024-37302?

Upgrade matrix-synapse to a fixed version for your release line: 1.106 or 1.106.0.

## Is CVE-2024-37302 being exploited?

There is no known exploitation of CVE-2024-37302 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2018-12423](https://insights.sbomify.com/CVE-2018-12423/): Matrix Synapse Authorization Error (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37302 and fix it if it is affected.

What it is: CVE-2024-37302 is a high-severity denial of service vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37302 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.106
- matrix-synapse (PyPI): affected all versions; fixed in 1.106
- matrix-synapse (PyPI): affected all versions; fixed in 1.106.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37302/ (Markdown: https://insights.sbomify.com/CVE-2024-37302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37302
- OSV: https://osv.dev/vulnerability/CVE-2024-37302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37302/
Summaries are generated and may contain mistakes; the official description above is the record.
