# CVE-2024-37303: Synapse unauthenticated writes to the media repository allow planting of problematic content

> Unauthenticated attackers can plant problematic content in the media repository by triggering remote media downloads, requiring an upgrade to enforce authentication.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-gjgr-7834-rhxr, PYSEC-2024-287, UBUNTU-CVE-2024-37303

## What is CVE-2024-37303?

CVE-2024-37303 is a medium-severity missing authorization vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver. Synapse before version 1.106 allows, by design, unauthenticated remote participants to trigger a download and caching of remote media from a remote homeserver to the local media repository. Such content then also becomes available for download from the local homeserver in an unauthenticated way. The implication is that unauthenticated remote adversaries can use this functionality to plant problematic content into the media repository. Synapse 1.106 introduces a partial mitigation in the form of new endpoints which require authentication for media downloads. The unauthenticated endpoints will be frozen in a future release, closing the attack vector.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-37303?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.106 |
| `matrix-synapse` | PyPI | All versions | 1.106 |
| `matrix-synapse` | PyPI | All versions | 1.106.0 |

Products: Matrix Synapse.

## How do I fix CVE-2024-37303?

Upgrade matrix-synapse to a fixed version for your release line: 1.106 or 1.106.0.

## Is CVE-2024-37303 being exploited?

There is no known exploitation of CVE-2024-37303 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37303 and fix it if it is affected.

What it is: CVE-2024-37303 is a medium-severity missing authorization vulnerability in element-hq synapse, published on 3 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37303 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.106
- matrix-synapse (PyPI): affected all versions; fixed in 1.106
- matrix-synapse (PyPI): affected all versions; fixed in 1.106.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37303/ (Markdown: https://insights.sbomify.com/CVE-2024-37303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37303
- OSV: https://osv.dev/vulnerability/CVE-2024-37303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37303/
Summaries are generated and may contain mistakes; the official description above is the record.
