CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Attackers with access to cilium-bugtool output can retrieve sensitive TLS certificates and API keys from specific Cilium configurations.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-37307?
CVE-2024-37307 is a high-severity vulnerability in cilium, published on 13 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.13.0 and prior to versions 1.13.7, 1.14.12, and 1.15.6, the output of `cilium-bugtool` can contain sensitive data when the tool is run (with the `--envoy-dump` flag set) against Cilium deployments with the Envoy proxy enabled. Users of the TLS inspection, Ingress with TLS termination, Gateway API with TLS termination, and Kafka network policies with API key filtering features are affected. The sensitive data includes the CA certificate, certificate chain, and private key used by Cilium HTTP Network Policies, and when using Ingress/Gateway API and the API keys used in Kafka-related network policy. `cilium-bugtool` is a debugging tool that is typically invoked manually and does not run during the normal operation of a Cilium cluster. This issue has been patched in Cilium v1.15.6, v1.14.12, and v1.13.17. There is no workaround to this issue.
Weakness: CWE-200
Which versions are affected by CVE-2024-37307?
14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
github.com/cilium/cilium Go | From 1.13.0 | 1.13.17 |
github.com/cilium/cilium Go | From 1.13.0 | 1.13.17 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.12 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.12 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.6 |
8 more packages
github.com/cilium/cilium Go | From 1.15.0 | 1.15.6 |
cilium Bitnami | From 1.15.4 | 1.15.6 |
cilium-operator Bitnami | From 1.15.4 | 1.15.6 |
cilium-proxy Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
hubble Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
hubble-relay Bitnami | From 1.13.0 | 1.15.6 |
hubble-ui Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
hubble-ui-backend Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
Products include Cilium Cilium.
How do I fix CVE-2024-37307?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.13.17, 1.14.12 or 1.15.6.
Is CVE-2024-37307 being exploited?
There is no known exploitation of CVE-2024-37307 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2023-39347 Cilium NetworkPolicy bypass via pod labels
Sources
Also known as BIT-cilium-2024-37307, BIT-cilium-operator-2024-37307, BIT-cilium-proxy-2024-37307, BIT-hubble-2024-37307, BIT-hubble-relay-2024-37307, BIT-hubble-ui-2024-37307 and 3 more.