# CVE-2024-37307: Cilium leaks sensitive information in cilium-bugtool

> Attackers with access to cilium-bugtool output can retrieve sensitive TLS certificates and API keys from specific Cilium configurations.

- **Severity:** High 7.9 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2024
- **Updated:** 19 Aug 2024
- **Also known as:** BIT-cilium-2024-37307, BIT-cilium-operator-2024-37307, BIT-cilium-proxy-2024-37307, BIT-hubble-2024-37307, BIT-hubble-relay-2024-37307, BIT-hubble-ui-2024-37307, BIT-hubble-ui-backend-2024-37307, GHSA-wh78-7948-358j, GO-2024-2922

## What is CVE-2024-37307?

CVE-2024-37307 is a high-severity vulnerability in cilium, published on 13 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.13.0 and prior to versions 1.13.7, 1.14.12, and 1.15.6, the output of `cilium-bugtool` can contain sensitive data when the tool is run (with the `--envoy-dump` flag set) against Cilium deployments with the Envoy proxy enabled. Users of the TLS inspection, Ingress with TLS termination, Gateway API with TLS termination, and Kafka network policies with API key filtering features are affected. The sensitive data includes the CA certificate, certificate chain, and private key used by Cilium HTTP Network Policies, and when using Ingress/Gateway API and the API keys used in Kafka-related network policy. `cilium-bugtool` is a debugging tool that is typically invoked manually and does not run during the normal operation of a Cilium cluster. This issue has been patched in Cilium v1.15.6, v1.14.12, and v1.13.17. There is no workaround to this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-37307?

14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.17 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.17 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.12 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.12 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.6 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.6 |
| `cilium` | Bitnami | From 1.15.4 | 1.15.6 |
| `cilium-operator` | Bitnami | From 1.15.4 | 1.15.6 |
| `cilium-proxy` | Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
| `hubble` | Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
| `hubble-relay` | Bitnami | From 1.13.0 | 1.15.6 |
| `hubble-ui` | Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |
| `hubble-ui-backend` | Bitnami | From 1.13.0 | 1.13.17, 1.14.12, 1.15.6 |

Products: Cilium Cilium.

## How do I fix CVE-2024-37307?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.13.17, 1.14.12 or 1.15.6.

## Is CVE-2024-37307 being exploited?

There is no known exploitation of CVE-2024-37307 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2023-39347](https://insights.sbomify.com/CVE-2023-39347/): Cilium NetworkPolicy bypass via pod labels (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37307 and fix it if it is affected.

What it is: CVE-2024-37307 is a high-severity vulnerability in cilium, published on 13 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37307 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.17, 1.14.12, 1.15.6
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.17
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.17
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.12
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.12
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.6
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.6
- cilium (Bitnami): affected from 1.15.4; fixed in 1.15.6
- cilium-operator (Bitnami): affected from 1.15.4; fixed in 1.15.6
- cilium-proxy (Bitnami): affected from 1.13.0; fixed in 1.13.17, 1.14.12, 1.15.6
- hubble (Bitnami): affected from 1.13.0; fixed in 1.13.17, 1.14.12, 1.15.6
- hubble-relay (Bitnami): affected from 1.13.0; fixed in 1.15.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37307/ (Markdown: https://insights.sbomify.com/CVE-2024-37307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37307
- OSV: https://osv.dev/vulnerability/CVE-2024-37307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37307/
Summaries are generated and may contain mistakes; the official description above is the record.
