{"answers":{"affected":"2 open source packages ship an affected version, including io.crate:crate. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37309 exists.","fix":"Upgrade io.crate:crate to 5.7.2 or later.","what":"CVE-2024-37309 is a medium-severity denial of service vulnerability in crate, published on 13 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-37309 and fix it if it is affected.\n\nWhat it is: CVE-2024-37309 is a medium-severity denial of service vulnerability in crate, published on 13 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37309 exists.\n\nAffected packages and fixed versions:\n- io.crate:crate (Maven): affected all versions; fixed in 5.7.2\n- io.crate:crate (Maven): affected all versions; fixed in 5.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37309/ (Markdown: https://insights.sbomify.com/CVE-2024-37309/index.md)","id":"CVE-2024-37309","markdown":"https://insights.sbomify.com/CVE-2024-37309/index.md","name":"CVE-2024-37309","record":{"aliases":["GHSA-x268-qpg6-w9g2"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CrateDB distributed SQL database","requires_auth":"none","summary":"An attacker can cause a denial of service in CrateDB by repeatedly triggering TLS renegotiations, exhausting server CPU resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cratedb","vendor":"cratedb"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"CrateDB is a distributed SQL database. A high-risk vulnerability has been identified in versions prior to 5.7.2 where the TLS endpoint (port 4200) permits client-initiated renegotiation. In this scenario, an attacker can exploit this feature to repeatedly request renegotiation of security parameters during an ongoing TLS session. This flaw could lead to excessive consumption of CPU resources, resulting in potential server overload and service disruption. The vulnerability was confirmed using an openssl client where the command `R` initiates renegotiation, followed by the server confirming with `RENEGOTIATING`. This vulnerability allows an attacker to perform a denial of service attack by exhausting server CPU resources through repeated TLS renegotiations. This impacts the availability of services running on the affected server, posing a significant risk to operational stability and security. TLS 1.3 explicitly forbids renegotiation, since it closes a window of opportunity for an attack. Version 5.7.2 of CrateDB contains the fix for the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Client initialized Session-Renegotiation DoS","id":"CVE-2024-37309","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"EVerest has an integer overflow in the \"v2g_incoming_v2gtp\" function","id":"CVE-2024-37310"},"packages":[{"ecosystem":"Maven","fixed":["5.7.2"],"introduced":["0"],"last_affected":[],"package":"io.crate:crate","purl":null,"source":"GHSA-x268-qpg6-w9g2"},{"ecosystem":"Maven","fixed":["5.7.2"],"introduced":["0"],"last_affected":[],"package":"io.crate:crate","purl":"pkg:maven/io.crate/crate","source":"GHSA-x268-qpg6-w9g2"}],"prev":{"headline":"WordPress Cooked Plugin - Authenticated (Contributor+) Persistent Cross-Site Scripting Vulnerability","id":"CVE-2024-37308"},"products":["crate"],"published":"2024-06-13","related":[{"cvss_score":9.8,"headline":"CrateDB authentication bypass vulnerability","id":"CVE-2023-51982","kev_date_added":null,"published":"2024-01-30"},{"cvss_score":5.7,"headline":"CrateDB database has an arbitrary file read vulnerability","id":"CVE-2024-24565","kev_date_added":null,"published":"2024-01-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["crate"]},"summary":"An attacker can cause a denial of service in CrateDB by repeatedly triggering TLS renegotiations, exhausting server CPU resources.","url":"https://insights.sbomify.com/CVE-2024-37309/"}