# CVE-2024-37309: Client initialized Session-Renegotiation DoS

> An attacker can cause a denial of service in CrateDB by repeatedly triggering TLS renegotiations, exhausting server CPU resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-x268-qpg6-w9g2

## What is CVE-2024-37309?

CVE-2024-37309 is a medium-severity denial of service vulnerability in crate, published on 13 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CrateDB is a distributed SQL database. A high-risk vulnerability has been identified in versions prior to 5.7.2 where the TLS endpoint (port 4200) permits client-initiated renegotiation. In this scenario, an attacker can exploit this feature to repeatedly request renegotiation of security parameters during an ongoing TLS session. This flaw could lead to excessive consumption of CPU resources, resulting in potential server overload and service disruption. The vulnerability was confirmed using an openssl client where the command `R` initiates renegotiation, followed by the server confirming with `RENEGOTIATING`. This vulnerability allows an attacker to perform a denial of service attack by exhausting server CPU resources through repeated TLS renegotiations. This impacts the availability of services running on the affected server, posing a significant risk to operational stability and security. TLS 1.3 explicitly forbids renegotiation, since it closes a window of opportunity for an attack. Version 5.7.2 of CrateDB contains the fix for the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-37309?

2 open source packages ship an affected version, including io.crate:crate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.crate:crate` | Maven | All versions | 5.7.2 |
| `io.crate:crate` | Maven | All versions | 5.7.2 |

Products: Cratedb Cratedb.

## How do I fix CVE-2024-37309?

Upgrade io.crate:crate to 5.7.2 or later.

## Is CVE-2024-37309 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37309 exists.

## Other vulnerabilities in crate

- [CVE-2023-51982](https://insights.sbomify.com/CVE-2023-51982/): CrateDB authentication bypass vulnerability (critical 9.8)
- [CVE-2024-24565](https://insights.sbomify.com/CVE-2024-24565/): CrateDB database has an arbitrary file read vulnerability (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37309 and fix it if it is affected.

What it is: CVE-2024-37309 is a medium-severity denial of service vulnerability in crate, published on 13 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37309 exists.

Affected packages and fixed versions:
- io.crate:crate (Maven): affected all versions; fixed in 5.7.2
- io.crate:crate (Maven): affected all versions; fixed in 5.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37309/ (Markdown: https://insights.sbomify.com/CVE-2024-37309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37309
- OSV: https://osv.dev/vulnerability/CVE-2024-37309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37309/
Summaries are generated and may contain mistakes; the official description above is the record.
