# CVE-2024-37358: Apache James: denial of service through the use of IMAP literals

> Attackers can cause denial of service in Apache James by abusing IMAP literals to trigger unbounded memory allocation and long computations.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2025
- **Updated:** 1 Sep 2025
- **Also known as:** GHSA-56jp-w6vw-j3jw

## What is CVE-2024-37358?

CVE-2024-37358 is a high-severity denial of service vulnerability in Apache James server, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Similarly to CVE-2024-34055, Apache James is vulnerable to denial of service through the abuse of IMAP literals from both authenticated and unauthenticated users, which could be used to cause unbounded memory allocation and very long computations

Version 3.7.6 and 3.8.2 restrict such illegitimate use of IMAP literals.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-37358?

4 open source packages ship an affected version, including org.apache.james.protocols:protocols-imap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james.protocols:protocols-imap` | Maven | All versions | 3.7.6 |
| `org.apache.james.protocols:protocols-imap` | Maven | All versions | 3.7.6 |
| `org.apache.james.protocols:protocols-imap` | Maven | From 3.8.0 | 3.8.2 |
| `org.apache.james.protocols:protocols-imap` | Maven | From 3.8.0 | 3.8.2 |

Products: Apache James Server.

## How do I fix CVE-2024-37358?

Upgrade org.apache.james.protocols:protocols-imap to a fixed version for your release line: 3.7.6 or 3.8.2.

## Is CVE-2024-37358 being exploited?

There is no known exploitation of CVE-2024-37358 in the wild and no public exploit code.

## Other vulnerabilities in Apache James server

- [CVE-2015-7611](https://insights.sbomify.com/CVE-2015-7611/): Apache James Server OS Command Injection (high 8.1)
- [CVE-2017-12628](https://insights.sbomify.com/CVE-2017-12628/): Apache James Privilege Escalation (high 7.8)
- [CVE-2024-45626](https://insights.sbomify.com/CVE-2024-45626/): Apache James: denial of service through JMAP HTML to text conversion (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37358 and fix it if it is affected.

What it is: CVE-2024-37358 is a high-severity denial of service vulnerability in Apache James server, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37358 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james.protocols:protocols-imap (Maven): affected all versions; fixed in 3.7.6
- org.apache.james.protocols:protocols-imap (Maven): affected all versions; fixed in 3.7.6
- org.apache.james.protocols:protocols-imap (Maven): affected from 3.8.0; fixed in 3.8.2
- org.apache.james.protocols:protocols-imap (Maven): affected from 3.8.0; fixed in 3.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37358/ (Markdown: https://insights.sbomify.com/CVE-2024-37358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37358
- OSV: https://osv.dev/vulnerability/CVE-2024-37358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37358/
Summaries are generated and may contain mistakes; the official description above is the record.
