{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.nifi:nifi-web-ui. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-37389 in the wild and no public exploit code.","fix":"Upgrade org.apache.nifi:nifi-web-ui to a fixed version for your release line: 1.27.0 or 2.0.0-M4.","what":"CVE-2024-37389 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 8 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-37389 and fix it if it is affected.\n\nWhat it is: CVE-2024-37389 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 8 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-37389 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.nifi:nifi-web-ui (Maven): affected from 1.10.0; fixed in 1.27.0\n- org.apache.nifi:nifi-web-ui (Maven): affected from 1.10.0; fixed in 1.27.0\n- org.apache.nifi:nifi-web-ui (Maven): affected from 2.0.0-M1; fixed in 2.0.0-M4\n- org.apache.nifi:nifi-web-ui (Maven): affected from 2.0.0-M1; fixed in 2.0.0-M4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37389/ (Markdown: https://insights.sbomify.com/CVE-2024-37389/index.md)","id":"CVE-2024-37389","markdown":"https://insights.sbomify.com/CVE-2024-37389/index.md","name":"CVE-2024-37389","record":{"aliases":["GHSA-h658-qqv9-qwv8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache NiFi","requires_auth":"low_privilege","summary":"Authenticated users can inject JavaScript into Parameter Context descriptions, leading to session hijacking or account takeover in Apache NiFi.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache NiFi: Improper Neutralization of Input in Parameter Context Description","id":"CVE-2024-37389","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:nifi","products":["apache:nifi"],"type":"xss","year":"2024"},"n_packages":4,"n_references":1,"next":{"headline":"Command injection in n/a","id":"CVE-2024-37391"},"packages":[{"ecosystem":"Maven","fixed":["1.27.0"],"introduced":["1.10.0"],"last_affected":[],"package":"org.apache.nifi:nifi-web-ui","purl":null,"source":"GHSA-h658-qqv9-qwv8"},{"ecosystem":"Maven","fixed":["1.27.0"],"introduced":["1.10.0"],"last_affected":[],"package":"org.apache.nifi:nifi-web-ui","purl":"pkg:maven/org.apache.nifi/nifi-web-ui","source":"GHSA-h658-qqv9-qwv8"},{"ecosystem":"Maven","fixed":["2.0.0-M4"],"introduced":["2.0.0-M1"],"last_affected":[],"package":"org.apache.nifi:nifi-web-ui","purl":null,"source":"GHSA-h658-qqv9-qwv8"},{"ecosystem":"Maven","fixed":["2.0.0-M4"],"introduced":["2.0.0-M1"],"last_affected":[],"package":"org.apache.nifi:nifi-web-ui","purl":"pkg:maven/org.apache.nifi/nifi-web-ui","source":"GHSA-h658-qqv9-qwv8"}],"prev":{"headline":"ebookmeta XML External Entity vulnerability","id":"CVE-2024-37388"},"products":["Apache NiFi"],"published":"2024-07-08","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-13","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can inject JavaScript into Parameter Context descriptions, leading to session hijacking or account takeover in Apache NiFi.","url":"https://insights.sbomify.com/CVE-2024-37389/"}