CVE-2024-3755 MF Gig Calendar <= 1.2.1 - Editor+ Stored XSS

Medium 5.4 Published Updated

High-privilege users can inject malicious scripts via unsanitized settings in the MF Gig Calendar plugin, leading to stored XSS attacks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-3755?

CVE-2024-3755 is a medium-severity cross-site scripting vulnerability in Unknown MF Gig Calendar, published on 6 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The MF Gig Calendar WordPress plugin through 1.2.1 does not sanitise and escape some of its settings, which could allow high privilege users such as editor to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Weakness: CWE-79

Which versions are affected by CVE-2024-3755?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.

PackageAffectedFixed in
wordpress BitnamiAll versions1.2.2
wordpress-multisite BitnamiAll versions1.2.2

Products include Mf Gig Calendar Project Mf Gig Calendar.

How do I fix CVE-2024-3755?

Upgrade wordpress to 1.2.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-3755 being exploited?

There is no known exploitation of CVE-2024-3755 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2024-3755, BIT-wordpress-multisite-2024-3755, GHSA-9g26-4h79-vm4x.

Is CVE-2024-3755 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free