CVE-2024-3756 MF Gig Calendar <= 1.2.1 - Arbitrary Event Deletion via CSRF
Attackers can trick logged-in users into deleting arbitrary events in the MF Gig Calendar WordPress plugin via CSRF.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-3756?
CVE-2024-3756 is a high-severity vulnerability in Unknown MF Gig Calendar, published on 6 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The MF Gig Calendar WordPress plugin through 1.2.1 does not have CSRF checks in some places, which could allow attackers to make logged in Contributors and above delete arbitrary events via a CSRF attack
Weakness: CWE-352
Which versions are affected by CVE-2024-3756?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | All versions | 1.2.2 |
wordpress-multisite Bitnami | All versions | 1.2.2 |
Products include Mf Gig Calendar Project Mf Gig Calendar.
How do I fix CVE-2024-3756?
Upgrade wordpress to 1.2.2 or later.
Is CVE-2024-3756 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3756 exists.
Other vulnerabilities in Unknown MF Gig Calendar
- CVE-2023-50842 WordPress MF Gig Calendar Plugin <= 1.2.1 is vulnerable to SQL Injection
- CVE-2023-37970 WordPress MF Gig Calendar Plugin <= 1.2 is vulnerable to Cross Site Scripting (XSS)
- CVE-2021-24510 MF Gig Calendar < 1.2 - Reflected Cross-Site Scripting (XSS)
- CVE-2024-3755 MF Gig Calendar <= 1.2.1 - Editor+ Stored XSS
- CVE-2024-33651 WordPress MF Gig Calendar plugin <= 1.2.1 - Cross Site Request Forgery (CSRF) vulnerability
Sources
Also known as BIT-wordpress-2024-3756, BIT-wordpress-multisite-2024-3756, GHSA-8q98-72mq-w92m.