{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3756 exists.","fix":"Upgrade wordpress to 1.2.2 or later.","what":"CVE-2024-3756 is a high-severity vulnerability in Unknown MF Gig Calendar, published on 6 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-3756 and fix it if it is affected.\n\nWhat it is: CVE-2024-3756 is a high-severity vulnerability in Unknown MF Gig Calendar, published on 6 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3756 exists.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 1.2.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3756/ (Markdown: https://insights.sbomify.com/CVE-2024-3756/index.md)","id":"CVE-2024-3756","markdown":"https://insights.sbomify.com/CVE-2024-3756/index.md","name":"CVE-2024-3756","record":{"aliases":["BIT-wordpress-2024-3756","BIT-wordpress-multisite-2024-3756","GHSA-8q98-72mq-w92m"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can trick logged-in users into deleting arbitrary events in the MF Gig Calendar WordPress plugin via CSRF.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"mf_gig_calendar","vendor":"mf_gig_calendar_project"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The MF Gig Calendar WordPress plugin through 1.2.1 does not have CSRF checks in some places, which could allow attackers to make logged in Contributors and above delete arbitrary events via a CSRF attack","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MF Gig Calendar \u003c= 1.2.1 - Arbitrary Event Deletion via CSRF","id":"CVE-2024-3756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Arkcompiler runtime has an integer overflow vulnerability","id":"CVE-2024-3757"},"packages":[{"ecosystem":"Bitnami","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-3756"},{"ecosystem":"Bitnami","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-3756"}],"prev":{"headline":"MF Gig Calendar \u003c= 1.2.1 - Editor+ Stored XSS","id":"CVE-2024-3755"},"products":["MF Gig Calendar"],"published":"2024-05-06","related":[{"cvss_score":8.5,"headline":"WordPress MF Gig Calendar Plugin \u003c= 1.2.1 is vulnerable to SQL Injection","id":"CVE-2023-50842","kev_date_added":null,"published":"2023-12-28"},{"cvss_score":6.5,"headline":"WordPress MF Gig Calendar Plugin \u003c= 1.2 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-37970","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":6.1,"headline":"MF Gig Calendar \u003c 1.2 - Reflected Cross-Site Scripting (XSS)","id":"CVE-2021-24510","kev_date_added":null,"published":"2021-09-13"},{"cvss_score":5.4,"headline":"MF Gig Calendar \u003c= 1.2.1 - Editor+ Stored XSS","id":"CVE-2024-3755","kev_date_added":null,"published":"2024-05-06"},{"cvss_score":5.4,"headline":"WordPress MF Gig Calendar plugin \u003c= 1.2.1 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-33651","kev_date_added":null,"published":"2024-04-26"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2012-4242","kev_date_added":null,"published":"2012-10-01"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["Unknown"]},"summary":"Attackers can trick logged-in users into deleting arbitrary events in the MF Gig Calendar WordPress plugin via CSRF.","url":"https://insights.sbomify.com/CVE-2024-3756/"}