# CVE-2024-37568: Authlib has algorithm confusion with asymmetric public keys

> Attackers can bypass JWT signature verification by using asymmetric public keys for HMAC validation, allowing unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-37568, ECHO-37cc-e0ec-bcbe, GHSA-5357-c2jx-v7qh, MGASA-2024-0238, PYSEC-2024-52, ROOT-APP-PYPI-CVE-2024-37568, SUSE-SU-2024:2064-1, UBUNTU-CVE-2024-37568, openSUSE-SU-2024:14035-1, openSUSE-SU-2026:11614-1

## What is CVE-2024-37568?

CVE-2024-37568 is a high-severity authentication bypass vulnerability in n/a, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lepture Authlib before 1.3.1 has algorithm confusion with asymmetric public keys. Unless an algorithm is specified in a jwt.decode call, HMAC verification is allowed with any asymmetric public key. (This is similar to CVE-2022-29217 and CVE-2024-33663.)

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-37568?

3 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.3.1 |
| `authlib` | PyPI | All versions | 1.3.1 |
| `authlib` | PyPI | All versions | 1.3.1 |
| `python-Authlib` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 1.3.1-150600.3.3.1 |
| `python-Authlib` | openSUSE:Leap 15.6 | All versions | 1.3.1-150600.3.3.1 |
| `python-Authlib` | openSUSE:Tumbleweed | All versions | 1.3.1-1.1 |
| `python-Authlib` | openSUSE:Tumbleweed | All versions | 1.7.2-3.1 |

Products: Authlib Authlib.

## How do I fix CVE-2024-37568?

Upgrade authlib to 1.3.1 or later.

## Is CVE-2024-37568 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37568 exists.

## Other vulnerabilities in n/a

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37568 and fix it if it is affected.

What it is: CVE-2024-37568 is a high-severity authentication bypass vulnerability in n/a, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37568 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.3.1
- authlib (PyPI): affected all versions; fixed in 1.3.1
- authlib (PyPI): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37568/ (Markdown: https://insights.sbomify.com/CVE-2024-37568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37568
- OSV: https://osv.dev/vulnerability/CVE-2024-37568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37568/
Summaries are generated and may contain mistakes; the official description above is the record.
