CVE-2024-3764 Tuya SDK MQTT Packet denial of service

Low 2.7 Published Updated

Remote attackers can cause denial of service in Tuya SDK via MQTT packets, though exploitation requires valid credentials or TLS bypass.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-3764?

CVE-2024-3764 is a low-severity denial of service vulnerability in Tuya SDK, published on 14 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

** DISPUTED ** A vulnerability classified as problematic has been found in Tuya SDK up to 5.0.x. Affected is an unknown function of the component MQTT Packet Handler. The manipulation leads to denial of service. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. Upgrading to version 5.1.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-260604. NOTE: The vendor explains that a malicious actor would have to crack TLS first or use a legitimate login to initiate the attack.

Weakness: CWE-404

Which versions are affected by CVE-2024-3764?

How do I fix CVE-2024-3764?

No fix has been published for CVE-2024-3764 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-3764 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3764 exists.

Sources

Also known as GHSA-46w5-56fc-wcpj.

Is CVE-2024-3764 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free