{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3764 exists.","fix":"No fix has been published for CVE-2024-3764 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-3764 is a low-severity denial of service vulnerability in Tuya SDK, published on 14 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-3764 and fix it if it is affected.\n\nWhat it is: CVE-2024-3764 is a low-severity denial of service vulnerability in Tuya SDK, published on 14 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3764 exists.\n\nAffected product: Tuya SDK. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3764/ (Markdown: https://insights.sbomify.com/CVE-2024-3764/index.md)","id":"CVE-2024-3764","markdown":"https://insights.sbomify.com/CVE-2024-3764/index.md","name":"CVE-2024-3764","record":{"aliases":["GHSA-46w5-56fc-wcpj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Tuya IoT SDK","requires_auth":"high_privilege","summary":"Remote attackers can cause denial of service in Tuya SDK via MQTT packets, though exploitation requires valid credentials or TLS bypass.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"** DISPUTED ** A vulnerability classified as problematic has been found in Tuya SDK up to 5.0.x. Affected is an unknown function of the component MQTT Packet Handler. The manipulation leads to denial of service. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. Upgrading to version 5.1.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-260604. NOTE: The vendor explains that a malicious actor would have to crack TLS first or use a legitimate login to initiate the attack.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Tuya SDK MQTT Packet denial of service","id":"CVE-2024-3764","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Xiongmai AHB7804R-MH-V2 Sofia Service access control","id":"CVE-2024-3765"},"packages":[],"prev":{"headline":"Emlog Pro Post Tag tag.php cross site scripting","id":"CVE-2024-3763"},"products":["SDK"],"published":"2024-04-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-26","vendors":["Tuya"]},"summary":"Remote attackers can cause denial of service in Tuya SDK via MQTT packets, though exploitation requires valid credentials or TLS bypass.","url":"https://insights.sbomify.com/CVE-2024-3764/"}