# CVE-2024-37674: Cross-site scripting in n/a

> Remote attackers can execute arbitrary code via XSS in Moodle CMS by manipulating the Field Name parameter of a new activity.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jun 2024
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-moodle-2024-37674, GHSA-fcqv-w7xc-5vmc, UBUNTU-CVE-2024-37674

## What is CVE-2024-37674?

CVE-2024-37674 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 20 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerability in Moodle CMS v3.10 allows a remote attacker to execute arbitrary code via the Field Name (name parameter) of a new activity.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-37674?

1 open source package ship an affected version, including moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle` | Bitnami | From 3.10.0 | 4.1.10 |

Products: Moodle Moodle.

## How do I fix CVE-2024-37674?

Upgrade moodle to 4.1.10 or later.

## Is CVE-2024-37674 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37674 exists.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37674 and fix it if it is affected.

What it is: CVE-2024-37674 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 20 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37674 exists.

Affected packages and fixed versions:
- moodle (Bitnami): affected from 3.10.0; fixed in 4.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37674/ (Markdown: https://insights.sbomify.com/CVE-2024-37674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37674
- OSV: https://osv.dev/vulnerability/CVE-2024-37674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37674/
Summaries are generated and may contain mistakes; the official description above is the record.
