{"answers":{"affected":"2 open source packages ship an affected version, including grumpydictator/firefly-iii.","exploited":"There is no known exploitation of CVE-2024-37893 in the wild and no public exploit code.","fix":"Upgrade grumpydictator/firefly-iii to 6.1.17 or later.","what":"CVE-2024-37893 is a medium-severity authentication bypass vulnerability in firefly-iii, published on 17 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-37893 and fix it if it is affected.\n\nWhat it is: CVE-2024-37893 is a medium-severity authentication bypass vulnerability in firefly-iii, published on 17 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-37893 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 6.1.17\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 6.1.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37893/ (Markdown: https://insights.sbomify.com/CVE-2024-37893/index.md)","id":"CVE-2024-37893","markdown":"https://insights.sbomify.com/CVE-2024-37893/index.md","name":"CVE-2024-37893","record":{"aliases":["GHSA-4gm4-c4mh-4p7w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Personal finance manager","requires_auth":"none","summary":"Attackers can bypass MFA in the OAuth flow to access user data if they possess valid credentials, requiring an upgrade to Firefly III.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"Firefly III is a free and open source personal finance manager. In affected versions an MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password. This problem has been patched in Firefly III v6.1.17 and up. Users are advised to upgrade. Users unable to upgrade should Use a unique password for their Firefly III instance and store their password securely, i.e. in a password manager.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MFA bypass in oauth flow in Firefly III","id":"CVE-2024-37893","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Squid vulnerable to heap corruption in ESI assign","id":"CVE-2024-37894"},"packages":[{"ecosystem":"Packagist","fixed":["6.1.17"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":null,"source":"GHSA-4gm4-c4mh-4p7w"},{"ecosystem":"Packagist","fixed":["6.1.17"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":"pkg:composer/grumpydictator/firefly-iii","source":"GHSA-4gm4-c4mh-4p7w"}],"prev":{"headline":"Proxy-Authorization request header isn't stripped during cross-origin redirects in urllib3","id":"CVE-2024-37891"},"products":["firefly-iii"],"published":"2024-06-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["firefly-iii"]},"summary":"Attackers can bypass MFA in the OAuth flow to access user data if they possess valid credentials, requiring an upgrade to Firefly III.","url":"https://insights.sbomify.com/CVE-2024-37893/"}