{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-37895 in the wild and no public exploit code.","fix":"Upgrade @lobehub/chat to 0.162.25 or later.","what":"CVE-2024-37895 is a medium-severity vulnerability in lobehub lobe-chat, published on 17 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-37895 and fix it if it is affected.\n\nWhat it is: CVE-2024-37895 is a medium-severity vulnerability in lobehub lobe-chat, published on 17 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-37895 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @lobehub/chat (npm): affected all versions; fixed in 0.162.25\n- @lobehub/chat (npm): affected all versions; fixed in 0.162.25\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37895/ (Markdown: https://insights.sbomify.com/CVE-2024-37895/index.md)","id":"CVE-2024-37895","markdown":"https://insights.sbomify.com/CVE-2024-37895/index.md","name":"CVE-2024-37895","record":{"aliases":["GHSA-p36r-qxgx-jq2v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI chat framework","requires_auth":"low_privilege","summary":"Authenticated attackers can leak backend API keys by manipulating the frontend base URL, exposing sensitive credentials in Lobe Chat.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lobe_chat","vendor":"lobehub"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Lobe Chat is an open-source LLMs/AI chat framework. In affected versions if an attacker can successfully authenticate through SSO/Access Code, they can obtain the real backend API Key by modifying the base URL to their own attack URL on the frontend and setting up a server-side request. This issue has been addressed in version 0.162.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"API Key Leak in lobe-chat","id":"CVE-2024-37895","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection vulnerability in Gin-vue-admin","id":"CVE-2024-37896"},"packages":[{"ecosystem":"npm","fixed":["0.162.25"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":null,"source":"GHSA-p36r-qxgx-jq2v"},{"ecosystem":"npm","fixed":["0.162.25"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":"pkg:npm/%40lobehub/chat","source":"GHSA-p36r-qxgx-jq2v"}],"prev":{"headline":"Squid vulnerable to heap corruption in ESI assign","id":"CVE-2024-37894"},"products":["lobe-chat"],"published":"2024-06-17","related":[{"cvss_score":9,"headline":"Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)","id":"CVE-2024-47066","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9,"headline":"lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability","id":"CVE-2024-32964","kev_date_added":null,"published":"2024-05-10"},{"cvss_score":8.1,"headline":"ssrf vulnerability in lobe-chat","id":"CVE-2024-32965","kev_date_added":null,"published":"2024-11-26"},{"cvss_score":6.8,"headline":"Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages","id":"CVE-2025-59417","kev_date_added":null,"published":"2025-09-18"},{"cvss_score":5.3,"headline":"Lobe Chat unauthorized access to plugins","id":"CVE-2024-24566","kev_date_added":null,"published":"2024-01-31"},{"cvss_score":4.3,"headline":"lobe-chat has an Open Redirect","id":"CVE-2025-59426","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["lobehub"]},"summary":"Authenticated attackers can leak backend API keys by manipulating the frontend base URL, exposing sensitive credentials in Lobe Chat.","url":"https://insights.sbomify.com/CVE-2024-37895/"}