# CVE-2024-37895: API Key Leak in lobe-chat

> Authenticated attackers can leak backend API keys by manipulating the frontend base URL, exposing sensitive credentials in Lobe Chat.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-p36r-qxgx-jq2v

## What is CVE-2024-37895?

CVE-2024-37895 is a medium-severity vulnerability in lobehub lobe-chat, published on 17 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Lobe Chat is an open-source LLMs/AI chat framework. In affected versions if an attacker can successfully authenticate through SSO/Access Code, they can obtain the real backend API Key by modifying the base URL to their own attack URL on the frontend and setting up a server-side request. This issue has been addressed in version 0.162.25. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-37895?

2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/chat` | npm | All versions | 0.162.25 |
| `@lobehub/chat` | npm | All versions | 0.162.25 |

Products: Lobehub Lobe Chat.

## How do I fix CVE-2024-37895?

Upgrade @lobehub/chat to 0.162.25 or later.

## Is CVE-2024-37895 being exploited?

There is no known exploitation of CVE-2024-37895 in the wild and no public exploit code.

## Other vulnerabilities in lobehub lobe-chat

- [CVE-2024-47066](https://insights.sbomify.com/CVE-2024-47066/): Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) (critical 9.0)
- [CVE-2024-32964](https://insights.sbomify.com/CVE-2024-32964/): lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability (critical 9.0)
- [CVE-2024-32965](https://insights.sbomify.com/CVE-2024-32965/): ssrf vulnerability in lobe-chat (high 8.1)
- [CVE-2025-59417](https://insights.sbomify.com/CVE-2025-59417/): Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages (medium 6.8)
- [CVE-2024-24566](https://insights.sbomify.com/CVE-2024-24566/): Lobe Chat unauthorized access to plugins (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37895 and fix it if it is affected.

What it is: CVE-2024-37895 is a medium-severity vulnerability in lobehub lobe-chat, published on 17 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-37895 in the wild and no public exploit code.

Affected packages and fixed versions:
- @lobehub/chat (npm): affected all versions; fixed in 0.162.25
- @lobehub/chat (npm): affected all versions; fixed in 0.162.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37895/ (Markdown: https://insights.sbomify.com/CVE-2024-37895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37895
- OSV: https://osv.dev/vulnerability/CVE-2024-37895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37895/
Summaries are generated and may contain mistakes; the official description above is the record.
