# CVE-2024-37896: SQL injection vulnerability in Gin-vue-admin

> Attackers can inject arbitrary SQL commands via unsanitized inputs to read or modify database data, requiring an upgrade to Gin-vue-admin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-gf3r-h744-mqgp, GO-2024-2928

## What is CVE-2024-37896?

CVE-2024-37896 is a high-severity SQL injection vulnerability in flipped-aurora gin-vue-admin, published on 17 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gin-vue-admin is a backstage management system based on vue and gin. Gin-vue-admin <= v2.6.5 has SQL injection vulnerability. The SQL injection vulnerabilities occur when a web application allows users to input data into SQL queries without sufficiently validating or sanitizing the input. Failing to properly enforce restrictions on user input could mean that even a basic form input field can be used to inject arbitrary and potentially dangerous SQL commands. This could lead to unauthorized access to the database, data leakage, data manipulation, or even complete compromise of the database server. This vulnerability has been addressed in commit `53d033821` which has been included in release version 2.6.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-37896?

1 open source package ship an affected version, including github.com/flipped-aurora/gin-vue-admin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/flipped-aurora/gin-vue-admin` | Go | All versions | 2.6.6+incompatible |

## How do I fix CVE-2024-37896?

Upgrade github.com/flipped-aurora/gin-vue-admin to 2.6.6+incompatible or later.

## Is CVE-2024-37896 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37896 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37896 and fix it if it is affected.

What it is: CVE-2024-37896 is a high-severity SQL injection vulnerability in flipped-aurora gin-vue-admin, published on 17 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-37896 exists.

Affected packages and fixed versions:
- github.com/flipped-aurora/gin-vue-admin (Go): affected all versions; fixed in 2.6.6+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37896/ (Markdown: https://insights.sbomify.com/CVE-2024-37896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37896
- OSV: https://osv.dev/vulnerability/CVE-2024-37896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37896/
Summaries are generated and may contain mistakes; the official description above is the record.
