{"answers":{"affected":"2 open source packages ship an affected version, including ai.djl:api.","exploited":"There is no known exploitation of CVE-2024-37902 in the wild and no public exploit code.","fix":"Upgrade ai.djl:api to 0.28.0 or later.","what":"CVE-2024-37902 is a critical path traversal vulnerability in deepjavalibrary djl, published on 17 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-37902 and fix it if it is affected.\n\nWhat it is: CVE-2024-37902 is a critical path traversal vulnerability in deepjavalibrary djl, published on 17 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-37902 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ai.djl:api (Maven): affected from 0.1.0; fixed in 0.28.0\n- ai.djl:api (Maven): affected from 0.1.0; fixed in 0.28.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-37902/ (Markdown: https://insights.sbomify.com/CVE-2024-37902/index.md)","id":"CVE-2024-37902","markdown":"https://insights.sbomify.com/CVE-2024-37902/index.md","name":"CVE-2024-37902","record":{"aliases":["GHSA-w877-jfw7-46rj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Java deep learning library","requires_auth":"none","summary":"Attackers can overwrite system files via absolute paths in archived artifacts, potentially leading to code execution or data modification.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"DeepJavaLibrary(DJL) is an Engine-Agnostic Deep Learning Framework in Java. DJL versions 0.1.0 through 0.27.0 do not prevent absolute path archived artifacts from inserting archived files directly into the system, overwriting system files. This is fixed in DJL 0.28.0 and patched in DJL Large Model Inference containers version 0.27.0. Users are advised to upgrade.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path thraversal in DeepJavaLibrary","id":"CVE-2024-37902","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Mastodon has improper authorship check on audience extension for existing posts","id":"CVE-2024-37903"},"packages":[{"ecosystem":"Maven","fixed":["0.28.0"],"introduced":["0.1.0"],"last_affected":[],"package":"ai.djl:api","purl":null,"source":"GHSA-w877-jfw7-46rj"},{"ecosystem":"Maven","fixed":["0.28.0"],"introduced":["0.1.0"],"last_affected":[],"package":"ai.djl:api","purl":"pkg:maven/ai.djl/api","source":"GHSA-w877-jfw7-46rj"}],"prev":{"headline":"XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet","id":"CVE-2024-37901"},"products":["djl"],"published":"2024-06-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["deepjavalibrary"]},"summary":"Attackers can overwrite system files via absolute paths in archived artifacts, potentially leading to code execution or data modification.","url":"https://insights.sbomify.com/CVE-2024-37902/"}