CVE-2024-37903 Mastodon has improper authorship check on audience extension for existing posts

High 8.2 Published Updated

Attackers can improperly extend the audience of posts they do not own, gaining unauthorized access to private content on Mastodon servers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-37903?

CVE-2024-37903 is a high-severity missing authorization vulnerability in mastodon, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Mastodon is a self-hosted, federated microblogging platform. Starting in version 2.6.0 and prior to versions 4.1.18 and 4.2.10, by crafting specific activities, an attacker can extend the audience of a post they do not own to other Mastodon users on a target server, thus gaining access to the contents of a post not intended for them. Versions 4.1.18 and 4.2.10 contain a patch for this issue.

Weakness: CWE-862

Which versions are affected by CVE-2024-37903?

1 open source package ship an affected version, including mastodon. It affects 1 product.

PackageAffectedFixed in
mastodon BitnamiFrom 2.6.04.1.18, 4.2.10

Products include Joinmastodon Mastodon.

How do I fix CVE-2024-37903?

Upgrade mastodon to a fixed version for your release line: 4.1.18 or 4.2.10.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-37903 being exploited?

There is no known exploitation of CVE-2024-37903 in the wild and no public exploit code.

Sources

Also known as BIT-mastodon-2024-37903, GHSA-xjvf-fm67-4qc3.

Is CVE-2024-37903 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free