CVE-2024-37905 Improper Access Control and Incorrect Authorization in github.com/goauthentik/authentik

High 8.8 Published Updated

Attackers can exploit the API access token mechanism to gain full admin privileges, allowing password resets and complete application control.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-37905?

CVE-2024-37905 is a high-severity vulnerability in goauthentik authentik, published on 28 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

authentik is an open-source Identity Provider that emphasizes flexibility and versatility. Authentik API-Access-Token mechanism can be exploited to gain admin user privileges. A successful exploit of the issue will result in a user gaining full admin access to the Authentik application, including resetting user passwords and more. This issue has been patched in version(s) 2024.2.4, 2024.4.2 and 2024.6.0.

Weakness: CWE-863, CWE-284

Which versions are affected by CVE-2024-37905?

1 open source package ship an affected version, including authentik. It affects 1 product.

PackageAffectedFixed in
authentik BitnamiAll versions2024.6.0

Products include Goauthentik Authentik.

How do I fix CVE-2024-37905?

Upgrade authentik to 2024.6.0 or later.

Is CVE-2024-37905 being exploited?

There is no known exploitation of CVE-2024-37905 in the wild and no public exploit code.

Sources

Also known as BIT-authentik-2024-37905, GHSA-c78c-2r9w-p7x4.

Is CVE-2024-37905 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free