# CVE-2024-37905: Improper Access Control and Incorrect Authorization in github.com/goauthentik/authentik

> Attackers can exploit the API access token mechanism to gain full admin privileges, allowing password resets and complete application control.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-authentik-2024-37905, GHSA-c78c-2r9w-p7x4

## What is CVE-2024-37905?

CVE-2024-37905 is a high-severity vulnerability in goauthentik authentik, published on 28 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

authentik is an open-source Identity Provider that emphasizes flexibility and versatility. Authentik API-Access-Token mechanism can be exploited to gain admin user privileges. A successful exploit of the issue will result in a user gaining full admin access to the Authentik application, including resetting user passwords and more. This issue has been patched in version(s) 2024.2.4, 2024.4.2 and 2024.6.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-37905?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2024.6.0 |

Products: Goauthentik Authentik.

## How do I fix CVE-2024-37905?

Upgrade authentik to 2024.6.0 or later.

## Is CVE-2024-37905 being exploited?

There is no known exploitation of CVE-2024-37905 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-37905 and fix it if it is affected.

What it is: CVE-2024-37905 is a high-severity vulnerability in goauthentik authentik, published on 28 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-37905 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2024.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-37905/ (Markdown: https://insights.sbomify.com/CVE-2024-37905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-37905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-37905
- OSV: https://osv.dev/vulnerability/CVE-2024-37905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-37905/
Summaries are generated and may contain mistakes; the official description above is the record.
