# CVE-2024-3817: HashiCorp go-getter Vulnerable to Argument Injection When Fetching Remote Default Git Branches

> Attackers can inject arguments into Git commands via remote branch discovery, potentially leading to arbitrary code execution in applications using the library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** AZL-39939, BELL-CVE-2024-3817, DEBIAN-CVE-2024-3817, GHSA-q64h-39hv-4cf7, GO-2024-2800, UBUNTU-CVE-2024-3817

## What is CVE-2024-3817?

CVE-2024-3817 is a critical command injection vulnerability in HashiCorp Shared library, published on 17 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp’s go-getter library is vulnerable to argument injection when executing Git to discover remote branches. 

This vulnerability does not affect the go-getter/v2 branch and package.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2024-3817?

3 open source packages ship an affected version, including github.com/hashicorp/go-getter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/go-getter` | Go | From 1.5.9 | 1.7.4 |
| `github.com/hashicorp/go-getter` | Go | From 1.5.9 | 1.7.4 |
| `github.com/hashicorp/go-getter` | Go | From 1.5.9 | 1.7.4 |

Products: Hashicorp Go-Getter.

## How do I fix CVE-2024-3817?

Upgrade github.com/hashicorp/go-getter to 1.7.4 or later.

## Is CVE-2024-3817 being exploited?

There is no known exploitation of CVE-2024-3817 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Shared library

- [CVE-2022-26945](https://insights.sbomify.com/CVE-2022-26945/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-30321](https://insights.sbomify.com/CVE-2022-30321/): Path traversal in n/a (high 8.6)
- [CVE-2022-30322](https://insights.sbomify.com/CVE-2022-30322/): Denial of service in n/a (high 8.6)
- [CVE-2022-30323](https://insights.sbomify.com/CVE-2022-30323/): Denial of service in n/a (high 8.6)
- [CVE-2024-6257](https://insights.sbomify.com/CVE-2024-6257/): HashiCorp go-getter Vulnerable to Code Execution On Git Update Via Git Config Manipulation (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3817 and fix it if it is affected.

What it is: CVE-2024-3817 is a critical command injection vulnerability in HashiCorp Shared library, published on 17 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-3817 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/go-getter (Go): affected from 1.5.9; fixed in 1.7.4
- github.com/hashicorp/go-getter (Go): affected from 1.5.9; fixed in 1.7.4
- github.com/hashicorp/go-getter (Go): affected from 1.5.9; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3817/ (Markdown: https://insights.sbomify.com/CVE-2024-3817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3817
- OSV: https://osv.dev/vulnerability/CVE-2024-3817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3817/
Summaries are generated and may contain mistakes; the official description above is the record.
