# CVE-2024-3825: CSRF in BlazeMeter Jenkins plugin

> A CSRF vulnerability in the BlazeMeter Jenkins plugin allows attackers to enumerate credentials.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-r52h-fjm7-93j8

## What is CVE-2024-3825?

CVE-2024-3825 is a medium-severity vulnerability in BlazeMeter Jenkins plugin, published on 17 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Versions of the BlazeMeter Jenkins plugin prior to 4.22 contain a flaw which results in credential enumeration

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-3825?

2 open source packages ship an affected version, including com.blazemeter.plugins:BlazeMeterJenkinsPlugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.blazemeter.plugins:BlazeMeterJenkinsPlugin` | Maven | All versions | 4.22 |
| `com.blazemeter.plugins:BlazeMeterJenkinsPlugin` | Maven | All versions | 4.22 |

## How do I fix CVE-2024-3825?

Upgrade com.blazemeter.plugins:BlazeMeterJenkinsPlugin to 4.22 or later.

## Is CVE-2024-3825 being exploited?

There is no known exploitation of CVE-2024-3825 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3825 and fix it if it is affected.

What it is: CVE-2024-3825 is a medium-severity vulnerability in BlazeMeter Jenkins plugin, published on 17 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-3825 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.blazemeter.plugins:BlazeMeterJenkinsPlugin (Maven): affected all versions; fixed in 4.22
- com.blazemeter.plugins:BlazeMeterJenkinsPlugin (Maven): affected all versions; fixed in 4.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3825/ (Markdown: https://insights.sbomify.com/CVE-2024-3825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3825
- OSV: https://osv.dev/vulnerability/CVE-2024-3825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3825/
Summaries are generated and may contain mistakes; the official description above is the record.
