CVE-2024-38275 moodle: HTTP authorization header is preserved between "emulated redirects"
Attackers can intercept sensitive HTTP authorization headers leaked during emulated redirects in Moodle's cURL wrapper.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-38275?
CVE-2024-38275 is a high-severity vulnerability in Moodle Moodle, published on 18 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The cURL wrapper in Moodle retained the original request headers when following redirects, so HTTP authorization header information could be unintentionally sent in requests to redirect URLs.
Which versions are affected by CVE-2024-38275?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.11 |
moodle/moodle Packagist | All versions | 4.1.11 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.8 |
moodle/moodle Packagist | From 4.2.0-beta | 4.2.8 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.5 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.5 |
3 more packages
moodle/moodle Packagist | From 4.4.0-beta | 4.4.1 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.1 |
moodle Bitnami | All versions | 4.1.11, 4.2.8, 4.3.5, 4.4.1 |
Products include Moodle Moodle.
How do I fix CVE-2024-38275?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.11, 4.2.8, 4.3.5 or 4.4.1.
Is CVE-2024-38275 being exploited?
There is no known exploitation of CVE-2024-38275 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-38275, GHSA-p2cj-86v4-7782, UBUNTU-CVE-2024-38275.