# CVE-2024-3829: Arbitrary File Read and Write during Snapshot Recovery in qdrant/qdrant

> Attackers can read or write arbitrary files on the server by manipulating symlinks in snapshot recovery, potentially leading to system takeover.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-7m75-x27w-r52r, PYSEC-2026-509

## What is CVE-2024-3829?

CVE-2024-3829 is a critical path traversal vulnerability in qdrant/qdrant, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

qdrant/qdrant version 1.9.0-dev is vulnerable to arbitrary file read and write during the snapshot recovery process. Attackers can exploit this vulnerability by manipulating snapshot files to include symlinks, leading to arbitrary file read by adding a symlink that points to a desired file on the filesystem and arbitrary file write by including a symlink and a payload file in the snapshot's directory structure. This vulnerability allows for the reading and writing of arbitrary files on the server, which could potentially lead to a full takeover of the system. The issue is fixed in version v1.9.0.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2024-3829?

3 open source packages ship an affected version, including qdrant-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qdrant-client` | PyPI | All versions | 1.9.0 |
| `qdrant-client` | PyPI | All versions | 1.9.0 |
| `qdrant-client` | PyPI | All versions | 1.9.0 |

Products: Qdrant Qdrant.

## How do I fix CVE-2024-3829?

Upgrade qdrant-client to 1.9.0 or later.

## Is CVE-2024-3829 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3829 exists.

Public exploit code:

- CVE-2024-3829 (github_poc): https://github.com/fabse-hack/CVE-2024-3829

## Other vulnerabilities in qdrant/qdrant

- [CVE-2024-3584](https://insights.sbomify.com/CVE-2024-3584/): Path Traversal in qdrant/qdrant (critical 9.8)
- [CVE-2024-2221](https://insights.sbomify.com/CVE-2024-2221/): Path Traversal and Arbitrary File Upload Vulnerability in qdrant/qdrant (critical 9.8)
- [CVE-2026-25628](https://insights.sbomify.com/CVE-2026-25628/): Qdrant affected by arbitrary file write via `/logger` endpoint (high 8.6)
- [CVE-2023-38975](https://insights.sbomify.com/CVE-2023-38975/): Memory corruption in n/a (high 7.5)
- [CVE-2024-3078](https://insights.sbomify.com/CVE-2024-3078/): Qdrant Full Snapshot REST API snapshots.rs path traversal (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3829 and fix it if it is affected.

What it is: CVE-2024-3829 is a critical path traversal vulnerability in qdrant/qdrant, published on 3 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3829 exists.

Affected packages and fixed versions:
- qdrant-client (PyPI): affected all versions; fixed in 1.9.0
- qdrant-client (PyPI): affected all versions; fixed in 1.9.0
- qdrant-client (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3829/ (Markdown: https://insights.sbomify.com/CVE-2024-3829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3829
- OSV: https://osv.dev/vulnerability/CVE-2024-3829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3829/
Summaries are generated and may contain mistakes; the official description above is the record.
