CVE-2024-38311 Apache Traffic Server: Request smuggling via pipelining after a chunked message body
Attackers can bypass security controls via request smuggling in Apache Traffic Server, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-38311?
CVE-2024-38311 is a medium-severity vulnerability in Apache Traffic Server, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Traffic Server.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3.
Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.
Weakness: CWE-20
Which versions are affected by CVE-2024-38311?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2024-38311?
Upgrade to a fixed version.
Is CVE-2024-38311 being exploited?
There is no known exploitation of CVE-2024-38311 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2024-38311, GHSA-53v8-xp2g-qpcw, UBUNTU-CVE-2024-38311.