CVE-2024-38351 Password auth and OAuth2 unverified email linking

Medium 5.4 Published Updated

Attackers can hijack accounts by pre-registering unverified emails before victims sign up via OAuth2, requiring both auth methods enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-38351?

CVE-2024-38351 is a medium-severity authentication bypass vulnerability in pocketbase, published on 18 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Pocketbase is an open source web backend written in go. In affected versions a malicious user may be able to compromise other user accounts. In order to be exploited users must have both OAuth2 and Password auth methods enabled. A possible attack scenario could be: 1. a malicious actor register with the targeted user's email (it is unverified), 2. at some later point in time the targeted user stumble on your app and decides to sign-up with OAuth2 (_this step could be also initiated by the attacker by sending an invite email to the targeted user_), 3. on successful OAuth2 auth we search for an existing PocketBase user matching with the OAuth2 user's email and associate them, 4. because we haven't changed the password of the existing PocketBase user during the linking, the malicious actor has access to the targeted user account and will be able to login with the initially created email/password. To prevent this for happening we now reset the password for this specific case if the previously created user wasn't verified (an exception to this is if the linking is explicit/manual, aka. when you send `Authorization:TOKEN` with the OAuth2 auth call). Additionally to warn existing users we now send an email alert in case the user has logged in with password but has at least one OAuth2 account linked. The flow will be further improved with ongoing refactoring and we will start sending emails for "unrecognized device" logins (OTP and MFA is already implemented and will be available with the next v0.23.0 release in the near future). For the time being users are advised to update to version 0.22.14. There are no known workarounds for this vulnerability.

Weakness: CWE-287

Which versions are affected by CVE-2024-38351?

3 open source packages ship an affected version, including github.com/pocketbase/pocketbase.

PackageAffectedFixed in
github.com/pocketbase/pocketbase GoAll versions0.22.14
github.com/pocketbase/pocketbase GoAll versions0.22.14
github.com/pocketbase/pocketbase GoAll versions0.22.14

How do I fix CVE-2024-38351?

Upgrade github.com/pocketbase/pocketbase to 0.22.14 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-38351 being exploited?

There is no known exploitation of CVE-2024-38351 in the wild and no public exploit code.

Sources

Also known as GHSA-m93w-4fxv-r35v, GO-2024-2936.

Is CVE-2024-38351 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free