{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pocketbase/pocketbase.","exploited":"There is no known exploitation of CVE-2024-38351 in the wild and no public exploit code.","fix":"Upgrade github.com/pocketbase/pocketbase to 0.22.14 or later.","what":"CVE-2024-38351 is a medium-severity authentication bypass vulnerability in pocketbase, published on 18 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-38351 and fix it if it is affected.\n\nWhat it is: CVE-2024-38351 is a medium-severity authentication bypass vulnerability in pocketbase, published on 18 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-38351 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.14\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.14\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38351/ (Markdown: https://insights.sbomify.com/CVE-2024-38351/index.md)","id":"CVE-2024-38351","markdown":"https://insights.sbomify.com/CVE-2024-38351/index.md","name":"CVE-2024-38351","record":{"aliases":["GHSA-m93w-4fxv-r35v","GO-2024-2936"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"PocketBase backend","requires_auth":"none","summary":"Attackers can hijack accounts by pre-registering unverified emails before victims sign up via OAuth2, requiring both auth methods enabled.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Pocketbase is an open source web backend written in go. In affected versions a malicious user may be able to compromise other user accounts. In order to be exploited users must have both OAuth2 and Password auth methods enabled. A possible attack scenario could be: 1. a malicious actor register with the targeted user's email (it is unverified), 2. at some later point in time the targeted user stumble on your app and decides to sign-up with OAuth2 (_this step could be also initiated by the attacker by sending an invite email to the targeted user_), 3. on successful OAuth2 auth we search for an existing PocketBase user matching with the OAuth2 user's email and associate them, 4. because we haven't changed the password of the existing PocketBase user during the linking, the malicious actor has access to the targeted user account and will be able to login with the initially created email/password. To prevent this for happening we now reset the password for this specific case if the previously created user wasn't verified (an exception to this is if the linking is explicit/manual, aka. when you send `Authorization:TOKEN` with the OAuth2 auth call). Additionally to warn existing users we now send an email alert in case the user has logged in with password but has at least one OAuth2 account linked. The flow will be further improved with ongoing refactoring and we will start sending emails for \"unrecognized device\" logins (OTP and MFA is already implemented and will be available with the next v0.23.0 release in the near future). For the time being users are advised to update to version 0.22.14. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Password auth and OAuth2 unverified email linking","id":"CVE-2024-38351","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"CVE was assigned in error.","id":"CVE-2024-38352"},"packages":[{"ecosystem":"Go","fixed":["0.22.14"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":null,"source":"GHSA-m93w-4fxv-r35v"},{"ecosystem":"Go","fixed":["0.22.14"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GHSA-m93w-4fxv-r35v"},{"ecosystem":"Go","fixed":["0.22.14"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GO-2024-2936"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2024-38348"},"products":["pocketbase"],"published":"2024-06-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["pocketbase"]},"summary":"Attackers can hijack accounts by pre-registering unverified emails before victims sign up via OAuth2, requiring both auth methods enabled.","url":"https://insights.sbomify.com/CVE-2024-38351/"}