# CVE-2024-38361: Permissions processing error in spacedb

> SpiceDB may incorrectly deny access to resources in multiple folders, causing legitimate users to lose permissions unexpectedly.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-grjv-gjgr-66g2, GO-2024-2939

## What is CVE-2024-38361?

CVE-2024-38361 is a low-severity missing authorization vulnerability in authzed spicedb, published on 20 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spicedb is an Open Source, Google Zanzibar-inspired permissions database to enable fine-grained authorization for customer applications. Use of an exclusion under an arrow that has multiple resources may resolve to `NO_PERMISSION` when permission is expected. If the resource exists under *multiple* folders and the user has access to view more than a single folder, SpiceDB may report the user does not have access due to a failure in the exclusion dispatcher to request that *all* the folders in which the user is a member be returned. Permission is returned as `NO_PERMISSION` when `PERMISSION` is expected on the `CheckPermission` API. This issue has been addressed in version 1.33.1. All users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2024-38361?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | All versions | 1.33.1 |
| `github.com/authzed/spicedb` | Go | All versions | 1.33.1 |
| `github.com/authzed/spicedb` | Go | All versions | 1.33.1 |

Products: Authzed Spicedb.

## How do I fix CVE-2024-38361?

Upgrade github.com/authzed/spicedb to 1.33.1 or later.

## Is CVE-2024-38361 being exploited?

There is no known exploitation of CVE-2024-38361 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38361 and fix it if it is affected.

What it is: CVE-2024-38361 is a low-severity missing authorization vulnerability in authzed spicedb, published on 20 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-38361 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.33.1
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.33.1
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.33.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38361/ (Markdown: https://insights.sbomify.com/CVE-2024-38361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38361
- OSV: https://osv.dev/vulnerability/CVE-2024-38361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38361/
Summaries are generated and may contain mistakes; the official description above is the record.
