CVE-2024-38370 GLPI allows API document download without rights
Attackers can download documents via the API without proper authorization, exposing sensitive data in GLPI IT management software.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-38370?
CVE-2024-38370 is a medium-severity missing authorization vulnerability in Glpi-Project Glpi, published on 15 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
GLPI is a free asset and IT management software package. Starting in 9.2.0 and prior to 11.0.0, it is possible to download a document from the API without appropriate rights. Upgrade to 10.0.16.
Weakness: CWE-285
Which versions are affected by CVE-2024-38370?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2024-38370?
No fix has been published for CVE-2024-38370 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-38370 being exploited?
There is no known exploitation of CVE-2024-38370 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-xrm2-m72w-w4x4, UBUNTU-CVE-2024-38370.