# CVE-2024-38372: Undici vulnerable to data leak when using response.arrayBuffer()

> Undici HTTP client may leak process memory via response.arrayBuffer(), allowing attackers to read sensitive data.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2024
- **Updated:** 28 Aug 2024
- **Also known as:** GHSA-3g92-w8c5-73pq, ROOT-APP-NPM-CVE-2024-38372, UBUNTU-CVE-2024-38372

## What is CVE-2024-38372?

CVE-2024-38372 is a low-severity vulnerability in nodejs undici, published on 8 Jul 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Undici is an HTTP/1.1 client, written from scratch for Node.js. Depending on network and process conditions of a `fetch()` request, `response.arrayBuffer()` might include portion of memory from the Node.js process. This has been patched in v6.19.2.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2024-38372?

2 open source packages ship an affected version, including undici.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 6.14.0 | 6.19.2 |
| `undici` | npm | From 6.14.0 | 6.19.2 |

## How do I fix CVE-2024-38372?

Upgrade undici to 6.19.2 or later.

## Is CVE-2024-38372 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38372 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38372 and fix it if it is affected.

What it is: CVE-2024-38372 is a low-severity vulnerability in nodejs undici, published on 8 Jul 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38372 exists.

Affected packages and fixed versions:
- undici (npm): affected from 6.14.0; fixed in 6.19.2
- undici (npm): affected from 6.14.0; fixed in 6.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38372/ (Markdown: https://insights.sbomify.com/CVE-2024-38372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38372
- OSV: https://osv.dev/vulnerability/CVE-2024-38372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38372/
Summaries are generated and may contain mistakes; the official description above is the record.
