CVE-2024-38375 @fastly/js-compute use-after-free in some host call implementations

Medium 5.3 Published Updated

A use-after-free bug in the Fastly JS Compute SDK can cause service crashes and potential data loss, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-38375?

CVE-2024-38375 is a medium-severity use after free vulnerability in fastly js-compute-runtime, published on 26 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

@fastly/js-compute is a JavaScript SDK and runtime for building Fastly Compute applications. The implementation of several functions were determined to include a use-after-free bug. This bug could allow for unintended data loss if the result of the preceding functions were sent anywhere else, and often results in a guest trap causing services to return a 500. This bug has been fixed in version 3.16.0 of the `@fastly/js-compute` package.

Weakness: CWE-416

Which versions are affected by CVE-2024-38375?

2 open source packages ship an affected version, including @fastly/js-compute.

PackageAffectedFixed in
@fastly/js-compute npmFrom 3.0.03.16.0
@fastly/js-compute npmFrom 3.0.03.16.0

How do I fix CVE-2024-38375?

Upgrade @fastly/js-compute to 3.16.0 or later.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2024-38375 being exploited?

There is no known exploitation of CVE-2024-38375 in the wild and no public exploit code.

Sources

Also known as GHSA-mp3g-vpm9-9vqv.

Is CVE-2024-38375 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free