{"answers":{"affected":"2 open source packages ship an affected version, including @fastly/js-compute.","exploited":"There is no known exploitation of CVE-2024-38375 in the wild and no public exploit code.","fix":"Upgrade @fastly/js-compute to 3.16.0 or later.","what":"CVE-2024-38375 is a medium-severity use after free vulnerability in fastly js-compute-runtime, published on 26 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-38375 and fix it if it is affected.\n\nWhat it is: CVE-2024-38375 is a medium-severity use after free vulnerability in fastly js-compute-runtime, published on 26 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-38375 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @fastly/js-compute (npm): affected from 3.0.0; fixed in 3.16.0\n- @fastly/js-compute (npm): affected from 3.0.0; fixed in 3.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38375/ (Markdown: https://insights.sbomify.com/CVE-2024-38375/index.md)","id":"CVE-2024-38375","markdown":"https://insights.sbomify.com/CVE-2024-38375/index.md","name":"CVE-2024-38375","record":{"aliases":["GHSA-mp3g-vpm9-9vqv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastly JS Compute SDK","requires_auth":"high_privilege","summary":"A use-after-free bug in the Fastly JS Compute SDK can cause service crashes and potential data loss, requiring an upgrade to the latest version.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"@fastly/js-compute is a JavaScript SDK and runtime for building Fastly Compute applications. The implementation of several functions were determined to include a use-after-free bug. This bug could allow for unintended data loss if the result of the preceding functions were sent anywhere else, and often results in a guest trap causing services to return a 500. This bug has been fixed in version 3.16.0 of the `@fastly/js-compute` package.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@fastly/js-compute use-after-free in some host call implementations","id":"CVE-2024-38375","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"use_after_free","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Allura: Stored authenticated XSS","id":"CVE-2024-38379"},"packages":[{"ecosystem":"npm","fixed":["3.16.0"],"introduced":["3.0.0"],"last_affected":[],"package":"@fastly/js-compute","purl":null,"source":"GHSA-mp3g-vpm9-9vqv"},{"ecosystem":"npm","fixed":["3.16.0"],"introduced":["3.0.0"],"last_affected":[],"package":"@fastly/js-compute","purl":"pkg:npm/%40fastly/js-compute","source":"GHSA-mp3g-vpm9-9vqv"}],"prev":{"headline":"Improper Restriction of XML External Entity Reference in org.cyclonedx:cyclonedx-core-java","id":"CVE-2024-38374"},"products":["js-compute-runtime"],"published":"2024-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["fastly"]},"summary":"A use-after-free bug in the Fastly JS Compute SDK can cause service crashes and potential data loss, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2024-38375/"}