CVE-2024-38379 Apache Allura: Stored authenticated XSS

Medium 4.8 Published Updated

Stored XSS in Apache Allura allows neighborhood admins to inject scripts, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-38379?

CVE-2024-38379 is a medium-severity cross-site scripting vulnerability in Apache Allura, published on 22 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Apache Allura's neighborhood settings are vulnerable to a stored XSS attack.  Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted.

This issue affects Apache Allura: from 1.4.0 through 1.17.0.

Users are recommended to upgrade to version 1.17.1, which fixes the issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-38379?

It affects 1 product.

Products include Apache Allura.

How do I fix CVE-2024-38379?

No fix has been published for CVE-2024-38379 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-38379 being exploited?

There is no known exploitation of CVE-2024-38379 in the wild and no public exploit code.

Sources

Also known as GHSA-7p4c-c4rq-7g98.

Is CVE-2024-38379 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free