{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-38448 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-38448 is a critical command injection vulnerability in n/a, published on 16 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-38448 and fix it if it is affected.\n\nWhat it is: CVE-2024-38448 is a critical command injection vulnerability in n/a, published on 16 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-38448 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38448/ (Markdown: https://insights.sbomify.com/CVE-2024-38448/index.md)","id":"CVE-2024-38448","markdown":"https://insights.sbomify.com/CVE-2024-38448/index.md","name":"CVE-2024-38448","record":{"aliases":["DEBIAN-CVE-2024-38448","GHSA-j4rp-pq8q-wm7r","UBUNTU-CVE-2024-38448","openSUSE-SU-2024:0210-1","openSUSE-SU-2024:14123-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"GNU Global source tagging","requires_auth":"none","summary":"Attackers can execute arbitrary code via shell metacharacters in the dbpath argument when using GNU Global with untrusted input.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.","ecosystems":["SUSE:Package Hub 15 SP5","SUSE:Package Hub 15 SP6","openSUSE:Leap 15.5","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2024-38448","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":5,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2024-38449"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["6.6.9-bp156.3.3.1"],"introduced":["0"],"last_affected":[],"package":"global","purl":"pkg:rpm/suse/global\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0210-1"},{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["6.6.9-bp156.3.3.1"],"introduced":["0"],"last_affected":[],"package":"global","purl":"pkg:rpm/suse/global\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2024:0210-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["6.6.9-bp156.3.3.1"],"introduced":["0"],"last_affected":[],"package":"global","purl":"pkg:rpm/opensuse/global\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0210-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["6.6.9-bp156.3.3.1"],"introduced":["0"],"last_affected":[],"package":"global","purl":"pkg:rpm/opensuse/global\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2024:0210-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.6.13-1.1"],"introduced":["0"],"last_affected":[],"package":"global","purl":"pkg:rpm/opensuse/global\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14123-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2024-38447"},"products":["n/a"],"published":"2024-06-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via shell metacharacters in the dbpath argument when using GNU Global with untrusted input.","url":"https://insights.sbomify.com/CVE-2024-38448/"}