{"answers":{"affected":"3 open source packages ship an affected version, including langchain-experimental. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-38459 in the wild and no public exploit code.","fix":"Upgrade langchain-experimental to 0.0.61 or later.","what":"CVE-2024-38459 is a high-severity code injection vulnerability in n/a, published on 16 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-38459 and fix it if it is affected.\n\nWhat it is: CVE-2024-38459 is a high-severity code injection vulnerability in n/a, published on 16 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-38459 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langchain-experimental (PyPI): affected all versions; fixed in 0.0.61\n- langchain-experimental (PyPI): affected all versions; fixed in 0.0.61\n- langchain-experimental (PyPI): affected all versions; fixed in 0.0.61\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-38459/ (Markdown: https://insights.sbomify.com/CVE-2024-38459/index.md)","id":"CVE-2024-38459","markdown":"https://insights.sbomify.com/CVE-2024-38459/index.md","name":"CVE-2024-38459","record":{"aliases":["GHSA-wmvm-9vqv-5qpp","PYSEC-2024-53"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"LangChain experimental library","requires_auth":"none","summary":"Attackers can execute arbitrary code via Python REPL access in LangChain Experimental due to missing opt-in requirements.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"langchain-experimental","vendor":"langchain"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"langchain_experimental (aka LangChain Experimental) before 0.0.61 for LangChain provides Python REPL access without an opt-in step. NOTE; this issue exists because of an incomplete fix for CVE-2024-27444.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"langchain_experimental Code Execution via Python REPL access","id":"CVE-2024-38459","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"SonarQube logs sensitive information","id":"CVE-2024-38460"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.61"],"introduced":["0"],"last_affected":[],"package":"langchain-experimental","purl":null,"source":"GHSA-wmvm-9vqv-5qpp"},{"ecosystem":"PyPI","fixed":["0.0.61"],"introduced":["0"],"last_affected":[],"package":"langchain-experimental","purl":"pkg:pypi/langchain-experimental","source":"GHSA-wmvm-9vqv-5qpp"},{"ecosystem":"PyPI","fixed":["0.0.61"],"introduced":["0"],"last_affected":[],"package":"langchain-experimental","purl":"pkg:pypi/langchain-experimental","source":"PYSEC-2024-53"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2024-38458"},"products":["n/a"],"published":"2024-06-16","related":[{"cvss_score":9.8,"headline":"LangChain Experimental Eval Injection vulnerability","id":"CVE-2024-46946","kev_date_added":null,"published":"2024-09-19"},{"cvss_score":9.8,"headline":"LangChain Experimental vulnerable to arbitrary code execution","id":"CVE-2024-27444","kev_date_added":null,"published":"2024-02-26"},{"cvss_score":8.5,"headline":"langchain-experimental vulnerable to Arbitrary Code Execution","id":"CVE-2024-21513","kev_date_added":null,"published":"2024-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via Python REPL access in LangChain Experimental due to missing opt-in requirements.","url":"https://insights.sbomify.com/CVE-2024-38459/"}