# CVE-2024-38472: Apache HTTP Server on WIndows UNC SSRF

> Attackers can exploit SSRF in Apache HTTP Server on Windows to leak NTLM hashes to malicious servers via crafted requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 18 Nov 2024
- **Also known as:** ALPINE-CVE-2024-38472, BIT-apache-2024-38472, CLEANSTART-2026-QV20553, GHSA-fjcc-r94c-wxr8

## What is CVE-2024-38472?

CVE-2024-38472 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SSRF in Apache HTTP Server on Windows allows to potentially leak NTLM hashes to a malicious server via SSRF and malicious requests or content 
Users are recommended to upgrade to version 2.4.60 which fixes this issue.  Note: Existing configurations that access UNC paths will have to configure new directive "UNCList" to allow access during request processing.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-38472?

1 open source package ship an affected version, including apache. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.60 |

Products: Apache Http Server, Netapp Ontap.

## How do I fix CVE-2024-38472?

Upgrade apache to 2.4.60 or later.

## Is CVE-2024-38472 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38472 exists.

Public exploit code:

- Apache HTTP Server Vulnerability Testing Tool | PoC for CVE-2024-38472 , CVE-2024-39573 , CVE-2024-38477 , CVE-2024-38476 , CVE-2024-38475 , CVE-2024-38474 ,  CVE-2024-38473 , CVE-2023-38709 (github_poc): https://github.com/mrmtwoj/apache-vulnerability-testing
- https://github.com/Abdurahmon3236/CVE-2024-38472 (github_poc): https://github.com/Abdurahmon3236/CVE-2024-38472
- Apache HTTPd Windows UNC - Server-Side Request Forgery (nuclei): http/cves/2024/CVE-2024-38472.yaml

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-38472 and fix it if it is affected.

What it is: CVE-2024-38472 is a high-severity server-side request forgery vulnerability in Apache Http Server, published on 1 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-38472 exists.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-38472/ (Markdown: https://insights.sbomify.com/CVE-2024-38472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-38472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-38472
- OSV: https://osv.dev/vulnerability/CVE-2024-38472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-38472/
Summaries are generated and may contain mistakes; the official description above is the record.
